20130322 (Friday, 22 March 2013)

Renamed users.Group to users.Team to avoid the name conflict with lino.utils.users.UserGroups. Because “Team” is how the users in Eupen call it. A Team is a group of users who meet regularily and have a common set of rules. lino.utils.users.UserGroups still should be renamed.

pcsw_demo_test is back. I disabled many of the hard-to-maintain cases and did a big effort to define and maintain list of queries to test.


There are tests which are much easier to write and maintain using doctest: new page welfare.specs.

Lino now defines a version of dtos which supports IncompleteDate.