Tuesday, October 10, 2017

Internal optimizations of accounting stuff

I continued to work on #2101:

It’s an old challenge for every accounting package how to organize the account chart. One aspect of this is which classification to use: PCMN or some international variant. The classification choice is usually not important for application code and should therefore be transparent. OTOH we need certain naming conventions.

I realized that CommonAccounts is something else than AccountTypes.

Side effects

  • New method lino.core.actors.Actor.is_installed()

  • The instantiator of a lino.core.choicelists.Choice() now supports being called without any argument at all (which makes sense only for subclasses which define a value as class attribute).

Bugfix deploy for Avanti

I upgraded the production site for Lino Avanti because Johanna had hundreds of false data problem messages “Need to update phonetic words” which did not disappear.

I also did some translations to German of several texts, e.g. “Sign in” (Thursday, September 21, 2017) wasn’t yet translated…